CVE-2019-20397

NameCVE-2019-20397
DescriptionA double-free is present in libyang before v1.0-r1 in the function yyparse() when an organization field is not terminated. Applications that use libyang to parse untrusted input yang files may be vulnerable to this flaw, which would cause a crash or potentially code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libyang (PTS)buster0.16.105-1+deb10u1vulnerable
bullseye0.16.105-3vulnerable
sid1.0.184-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libyangsourceexperimental1.0.167-1
libyangsource(unstable)1.0.176-1

Notes

[buster] - libyang <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1793928
https://github.com/CESNET/libyang/commit/88bd6c548ba79bce176cd875e9b56e7e0ef4d8d4
https://github.com/CESNET/libyang/issues/739

Search for package or bug name: Reporting problems