CVE-2019-20444

NameCVE-2019-20444
DescriptionHttpObjectDecoder.java in Netty before 4.1.44 allows an HTTP header that lacks a colon, which might be interpreted as a separate header with an incorrect syntax, or might be interpreted as an "invalid fold."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2109-1, DLA-2110-1
NVD severitymedium
Debian Bugs950966

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netty (PTS)jessie1:3.2.6.Final-2vulnerable
jessie (security)1:3.2.6.Final-2+deb8u2fixed
stretch (security), stretch1:4.1.7-2+deb9u1vulnerable
buster, buster (security)1:4.1.33-1+deb10u1vulnerable
bullseye1:4.1.33-3vulnerable
sid1:4.1.45-1fixed
netty-3.9 (PTS)jessie3.9.0.Final-1vulnerable
jessie (security)3.9.0.Final-1+deb8u1fixed
stretch3.9.9.Final-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nettysource(unstable)1:4.1.45-1950966
nettysourcejessie1:3.2.6.Final-2+deb8u2DLA-2109-1
netty-3.9source(unstable)(unfixed)
netty-3.9sourcejessie3.9.0.Final-1+deb8u1DLA-2110-1

Notes

https://github.com/netty/netty/issues/9866
https://github.com/netty/netty/commit/a7c18d44b46e02dadfe3da225a06e5091f5f328e (4.1)

Search for package or bug name: Reporting problems