CVE-2019-20446

NameCVE-2019-20446
DescriptionIn xml.rs in GNOME librsvg before 2.46.2, a crafted SVG file with nested patterns can cause denial of service when passed to the library for processing. The attacker constructs pattern elements so that the number of final rendered objects grows exponentially.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2285-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
librsvg (PTS)buster2.44.10-2.1vulnerable
bullseye2.50.3+dfsg-1fixed
bookworm, sid2.54.4+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librsvgsourcestretch2.40.21-0+deb9u1DLA-2285-1
librsvgsource(unstable)2.46.4-1

Notes

[buster] - librsvg <no-dsa> (Will be fixed via spu)
[jessie] - librsvg <no-dsa> (Minor issue)
https://gitlab.gnome.org/GNOME/librsvg/issues/515
https://gitlab.gnome.org/GNOME/librsvg/commit/572f95f739529b865e2717664d6fefcef9493135

Search for package or bug name: Reporting problems