CVE-2019-20788

NameCVE-2019-20788
Descriptionlibvncclient/cursor.c in LibVNCServer through 0.9.12 has a HandleCursorShape integer overflow and heap-based buffer overflow via a large height or width value. NOTE: this may overlap CVE-2019-15690.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2146-1
NVD severityhigh
Debian Bugs954163

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvncserver (PTS)stretch0.9.11+dfsg-1.3~deb9u4fixed
stretch (security)0.9.11+dfsg-1.3~deb9u5fixed
buster0.9.11+dfsg-1.3+deb10u4fixed
bullseye, sid0.9.13+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvncserversourcejessie0.9.9+dfsg2-6.1+deb8u7DLA-2146-1
libvncserversourcestretch0.9.11+dfsg-1.3~deb9u4
libvncserversourcebuster0.9.11+dfsg-1.3+deb10u3
libvncserversource(unstable)0.9.12+dfsg-9954163

Notes

https://github.com/LibVNC/libvncserver/commit/54220248886b5001fbbb9fa73c4e1a2cb9413fed

Search for package or bug name: Reporting problems