CVE-2019-20840

NameCVE-2019-20840
DescriptionAn issue was discovered in LibVNCServer before 0.9.13. libvncserver/ws_decode.c can lead to a crash because of unaligned accesses in hybiReadAndDecode.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvncserver (PTS)stretch0.9.11+dfsg-1.3~deb9u4vulnerable
stretch (security)0.9.11+dfsg-1.3~deb9u1vulnerable
buster0.9.11+dfsg-1.3+deb10u3vulnerable
bullseye, sid0.9.13+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvncserversourcejessie(not affected)
libvncserversource(unstable)0.9.13+dfsg-1

Notes

[jessie] - libvncserver <not-affected> (Vulnerable code not present)
https://github.com/LibVNC/libvncserver/commit/0cf1400c61850065de590d403f6d49e32882fd76

Search for package or bug name: Reporting problems