DescriptionAn issue was discovered in LibVNCServer before 0.9.13. libvncserver/ws_decode.c can lead to a crash because of unaligned accesses in hybiReadAndDecode.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvncserver (PTS)stretch0.9.11+dfsg-1.3~deb9u4fixed
stretch (security)0.9.11+dfsg-1.3~deb9u6fixed
bullseye, sid0.9.13+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvncserversourcejessie(not affected)
libvncserversourcestretch(not affected)
libvncserversourcebuster(not affected)


[buster] - libvncserver <not-affected> (Vulnerable code not present)
[stretch] - libvncserver <not-affected> (Vulnerable code not present)
[jessie] - libvncserver <not-affected> (Vulnerable code not present)
Vulnerable code is introduced with the fix for CVE-2017-18922.

Search for package or bug name: Reporting problems