CVE-2019-25078

NameCVE-2019-25078
DescriptionA vulnerability classified as problematic was found in pacparser up to 1.3.x. Affected by this vulnerability is the function pacparser_find_proxy of the file src/pacparser.c. The manipulation of the argument url leads to buffer overflow. Attacking locally is a requirement. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is 853e8f45607cb07b877ffd270c63dbcdd5201ad9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215443.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1026106

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pacparser (PTS)buster1.3.6-1.1vulnerable
bullseye1.3.6-1.2vulnerable
bookworm, sid1.3.6-1.3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pacparsersource(unstable)(unfixed)1026106

Notes

[bullseye] - pacparser <no-dsa> (Minor issue)
[buster] - pacparser <no-dsa> (Minor issue)
https://github.com/manugarg/pacparser/issues/99
https://github.com/manugarg/pacparser/commit/853e8f45607cb07b877ffd270c63dbcdd5201ad9 (v1.4.0)

Search for package or bug name: Reporting problems