CVE-2019-2602

NameCVE-2019-2602
DescriptionVulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Libraries). Supported versions that are affected are Java SE: 7u211, 8u202, 11.0.2 and 12; Java SE Embedded: 8u201. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of Java SE, Java SE Embedded. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.0 Base Score 7.5 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1782-1, DSA-4453-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openjdk-11 (PTS)buster11.0.3+1-1vulnerable
sid11.0.4+4+really11.0.3+7-2fixed
openjdk-7 (PTS)jessie7u181-2.6.14-1~deb8u1vulnerable
jessie (security)7u221-2.6.18-1~deb8u1fixed
openjdk-8 (PTS)stretch8u212-b01-1~deb9u1vulnerable
stretch (security)8u212-b03-2~deb9u1fixed
sid8u212-b03-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjdk-11source(unstable)11.0.3+7-1medium
openjdk-7source(unstable)(unfixed)medium
openjdk-7sourcejessie7u221-2.6.18-1~deb8u1mediumDLA-1782-1
openjdk-8source(unstable)8u212-b03-1medium
openjdk-8sourcestretch8u212-b03-2~deb9u1mediumDSA-4453-1

Search for package or bug name: Reporting problems