CVE-2019-3826

NameCVE-2019-3826
DescriptionA stored, DOM based, cross-site scripting (XSS) flaw was found in Prometheus before version 2.7.1. An attacker could exploit this by convincing an authenticated user to visit a crafted URL on a Prometheus server, allowing for the execution and persistent storage of arbitrary scripts.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs921615

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
prometheus (PTS)stretch1.5.2+ds-2fixed
bullseye, sid, buster2.7.1+ds-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
prometheussource(unstable)2.7.1+ds-1medium921615
prometheussourcestretch(not affected)

Notes

[stretch] - prometheus <not-affected> (Only affects 2.1.0 onwards)
https://github.com/prometheus/prometheus/pull/5163

Search for package or bug name: Reporting problems