CVE-2019-3827

NameCVE-2019-3827
DescriptionAn incorrect permission check in the admin backend in gvfs before version 1.39.4 was found that allows reading and modify arbitrary files by privileged users without asking for password when no authentication agent is running. This vulnerability can be exploited by malicious programs running under privileges of users belonging to the wheel group to further escalate its privileges by modifying system files without user's knowledge. Successful exploitation requires uncommon system configuration.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: local)
Debian Bugs921816

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gvfs (PTS)jessie1.22.2-1fixed
stretch1.30.4-1vulnerable
buster, sid1.38.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gvfssource(unstable)1.38.1-3low921816
gvfssourcejessie(not affected)

Notes

[stretch] - gvfs <no-dsa> (Minor issue)
[jessie] - gvfs <not-affected> (Vulnerable code not present)
https://gitlab.gnome.org/GNOME/gvfs/issues/355
https://bugzilla.redhat.com/show_bug.cgi?id=1665578
Affecting gvfs since 1.29.4 where admin backend was introduced.

Search for package or bug name: Reporting problems