DescriptionAn incorrect permission check in the admin backend in gvfs before version 1.39.4 was found that allows reading and modify arbitrary files by privileged users without asking for password when no authentication agent is running. This vulnerability can be exploited by malicious programs running under privileges of users belonging to the wheel group to further escalate its privileges by modifying system files without user's knowledge. Successful exploitation requires uncommon system configuration.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs921816

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gvfs (PTS)bullseye1.46.2-1fixed
sid, trixie1.54.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gvfssourcejessie(not affected)


[stretch] - gvfs <no-dsa> (Minor issue)
[jessie] - gvfs <not-affected> (Vulnerable code not present)
Affecting gvfs since 1.29.4 where admin backend was introduced.

Search for package or bug name: Reporting problems