CVE-2019-3828

NameCVE-2019-3828
DescriptionAnsible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files outside of the specified destination in the local ansible controller host, by not restricting an absolute path.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4396-1
NVD severityhigh (attack range: remote)
Debian Bugs922537

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ansible (PTS)jessie1.7.2+dfsg-2fixed
jessie (security)1.7.2+dfsg-2+deb8u1fixed
stretch (security), stretch2.2.1.0-2+deb9u1fixed
buster2.7.7+dfsg-1fixed
bullseye2.7.8+dfsg-1fixed
sid2.8.3+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ansiblesource(unstable)2.7.7+dfsg-1high922537
ansiblesourcejessie(not affected)
ansiblesourcestretch2.2.1.0-2+deb9u1highDSA-4396-1

Notes

[jessie] - ansible <not-affected> (Vulnerable code not present)
https://bugzilla.redhat.com/show_bug.cgi?id=1676689
https://github.com/ansible/ansible/pull/52133

Search for package or bug name: Reporting problems