CVE-2019-3866

NameCVE-2019-3866
DescriptionAn information-exposure vulnerability was discovered where openstack-mistral's undercloud log files containing clear-text information were made world readable. A malicious system user could exploit this flaw to access sensitive user information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs946060

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mistral (PTS)stretch3.0.0-4+deb9u1vulnerable
buster7.0.0-2fixed
bullseye, sid10.0.0-1fixed
python-mistral-lib (PTS)buster1.0.0-1vulnerable
bullseye, sid2.1.0-2fixed
python-oslo.utils (PTS)stretch3.16.0-2vulnerable
buster3.36.5-0+deb10u1fixed
bullseye4.1.1-4fixed
sid4.1.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mistralsource(unstable)5.1.0-2
python-mistral-libsource(unstable)1.2.0-3
python-oslo.utilssource(unstable)3.41.3-1low946060
python-oslo.utilssourcebuster3.36.5-0+deb10u1
python-oslo.utilssourcejessie(not affected)

Notes

[stretch] - python-oslo.utils <no-dsa> (Minor issue; can be fixed via point release)
[jessie] - python-oslo.utils <not-affected> (regex pattern rewrite)
[buster] - python-mistral-lib <no-dsa> (Minor issue)
[stretch] - mistral <no-dsa> (Minor issue; can be fixed via point release)
In mistral/5.0.0 the problematic code was moved to the python library.
To be apply the fixes in mistral/python-mistral-lib as pre-requiste the
python-oslo.utils package needs an update.
https://bugzilla.redhat.com/show_bug.cgi?id=1768731
https://bugs.launchpad.net/tripleo/+bug/1850843
https://opendev.org/openstack/oslo.utils/commit/b41268417cecb12d1d5955ee3107067edf050221
Patch for Pike and newer: https://launchpadlibrarian.net/449473654/0001-Ensure-we-mask-sensitive-data-from-Mistral-Action-lo.patch
Patch for Pike and newer: https://launchpadlibrarian.net/449472809/0001-Ensure-we-mask-sensitive-data-from-Mistral-Action-lo.patch

Search for package or bug name: Reporting problems