CVE-2019-3902

NameCVE-2019-3902
DescriptionA flaw was found in Mercurial before 4.9. It was possible to use symlinks and subrepositories to defeat Mercurial's path-checking logic and write files outside a repository.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1764-1
NVD severitymedium (attack range: remote)
Debian Bugs927674

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mercurial (PTS)jessie3.1.2-2+deb8u4vulnerable
jessie (security)3.1.2-2+deb8u7fixed
stretch (security), stretch4.0-1+deb9u1vulnerable
buster4.8.2-1+deb10u1fixed
bullseye, sid4.9-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mercurialsource(unstable)4.9-1medium927674
mercurialsourcebuster4.8.2-1+deb10u1medium
mercurialsourcejessie3.1.2-2+deb8u7mediumDLA-1764-1

Notes

https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.9_.282019-02-01.29
https://www.mercurial-scm.org/repo/hg/rev/6c10eba6b9cd
https://www.mercurial-scm.org/repo/hg/rev/31286c9282df
https://www.mercurial-scm.org/repo/hg/rev/83377b4b4ae0

Search for package or bug name: Reporting problems