CVE-2019-5429

NameCVE-2019-5429
DescriptionUntrusted search path in FileZilla before 3.41.0-rc1 allows an attacker to gain privileges via a malicious 'fzsftp' binary in the user's home directory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs928282

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
filezilla (PTS)jessie3.9.0.5-1vulnerable
stretch3.24.0-1vulnerable
buster3.39.0-2vulnerable
bullseye, sid3.45.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filezillasource(unstable)3.45.1-1low928282

Notes

[buster] - filezilla <no-dsa> (Minor issue)
[stretch] - filezilla <no-dsa> (Minor issue)
[jessie] - filezilla <no-dsa> (Minor issue)
https://svn.filezilla-project.org/filezilla?revision=9097&view=revision
https://www.tenable.com/security/research/tra-2019-14

Search for package or bug name: Reporting problems