CVE-2019-5882

NameCVE-2019-5882
DescriptionIrssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs918865

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)jessie (security), jessie0.8.17-1+deb8u5fixed
stretch (security), stretch1.0.7-1~deb9u1fixed
buster, sid1.1.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
irssisource(unstable)1.1.2-1918865
irssisourcejessie(not affected)
irssisourcestretch(not affected)

Notes

[stretch] - irssi <not-affected> (Vulnerable code not present)
[jessie] - irssi <not-affected> (Vulnerable code not present)
https://irssi.org/security/irssi_sa_2019_01.txt
https://github.com/irssi/irssi/pull/948
https://github.com/irssi/irssi//commit/8684ccb45c267fdeaaa779fce9323047aa5a9e38
Introduced with support for hidden lines in https://github.com/irssi/irssi/commit/8dfeca57ede1e726de07522a87203ce13676882d

Search for package or bug name: Reporting problems