CVE-2019-6133

NameCVE-2019-6133
DescriptionIn PolicyKit (aka polkit) 0.115, the "start time" protection mechanism can be bypassed because fork() is not atomic, and therefore authorization decisions are improperly cached. This is related to lack of uid checking in polkitbackend/polkitbackendinteractiveauthority.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1644-1
NVD severitymedium (attack range: local)
Debian Bugs918985

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
policykit-1 (PTS)jessie0.105-15~deb8u2vulnerable
jessie (security)0.105-15~deb8u4fixed
stretch (security), stretch0.105-18+deb9u1vulnerable
buster, sid0.105-25fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
policykit-1source(unstable)0.105-25medium918985
policykit-1sourcejessie0.105-15~deb8u4mediumDLA-1644-1

Notes

[stretch] - policykit-1 <no-dsa> (Minor issue, kernel mitigation will land in next 4.9.x rebase)
https://bugs.chromium.org/p/project-zero/issues/detail?id=1692
https://gitlab.freedesktop.org/polkit/polkit/merge_requests/19
https://gitlab.freedesktop.org/polkit/polkit/commit/c898fdf4b1aafaa04f8ada9d73d77c8bb76e2f81
Issue can be mitigated in kernel with
https://git.kernel.org/linus/7b55851367136b1efd84d98fea81ba57a98304cf (landed in 4.9.150)

Search for package or bug name: Reporting problems