CVE-2019-6250

NameCVE-2019-6250
DescriptionA pointer overflow, with code execution, was discovered in ZeroMQ libzmq (aka 0MQ) 4.2.x and 4.3.x before 4.3.1. A v2_decoder.cpp zmq::v2_decoder_t::size_ready integer overflow allows an authenticated attacker to overwrite an arbitrary amount of bytes beyond the bounds of a buffer, which can be leveraged to run arbitrary code on the target system. The memory layout allows the attacker to inject OS commands into a data structure located immediately after the problematic buffer (i.e., it is not necessary to use a typical buffer-overflow exploitation technique that changes the flow of control).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4368-1
NVD severityhigh (attack range: remote)
Debian Bugs919098

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zeromq3 (PTS)jessie (security), jessie4.0.5+dfsg-2+deb8u1fixed
stretch (security), stretch4.2.1-4+deb9u1fixed
buster, sid4.3.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zeromq3source(unstable)4.3.1-1high919098
zeromq3sourcejessie(not affected)
zeromq3sourcestretch4.2.1-4+deb9u1highDSA-4368-1

Notes

[jessie] - zeromq3 <not-affected> (Vulnerable code introduced later)
https://github.com/zeromq/libzmq/issues/3351

Search for package or bug name: Reporting problems