CVE-2019-6256

NameCVE-2019-6256
DescriptionA Denial of Service issue was discovered in the LIVE555 Streaming Media libraries as used in Live555 Media Server 0.93. It can cause an RTSPServer crash in handleHTTPCmd_TunnelingPOST, when RTSP-over-HTTP tunneling is supported, via x-sessioncookie HTTP headers in a GET request and a POST request within the same TCP session. This occurs because of a call to an incorrect virtual function pointer in the readSocket function in GroupsockHelper.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1690-1, DSA-4408-1
NVD severityhigh (attack range: remote)
Debian Bugs919529

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
liblivemedia (PTS)jessie2014.01.13-1vulnerable
jessie (security)2014.01.13-1+deb8u3fixed
stretch (security), stretch2016.11.28-1+deb9u2fixed
bullseye, sid, buster2018.11.26-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
liblivemediasource(unstable)2018.11.26-1high919529
liblivemediasourcejessie2014.01.13-1+deb8u2highDLA-1690-1
liblivemediasourcestretch2016.11.28-1+deb9u2highDSA-4408-1

Notes

https://github.com/rgaufman/live555/issues/19

Search for package or bug name: Reporting problems