CVE-2019-6438

NameCVE-2019-6438
DescriptionSchedMD Slurm before 17.11.13 and 18.x before 18.08.5 mishandles 32-bit systems.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs920997

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slurm-llnl (PTS)jessie14.03.9-5+deb8u2vulnerable
jessie (security)14.03.9-5+deb8u4vulnerable
stretch (security), stretch16.05.9-1+deb9u2vulnerable
buster18.08.5.2-1fixed
sid18.08.6.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slurm-llnlsource(unstable)18.08.5.2-1low920997

Notes

[stretch] - slurm-llnl <no-dsa> (Minor issue)
[jessie] - slurm-llnl <no-dsa> (Minor issue)
https://www.schedmd.com/news.php?id=213
https://lists.schedmd.com/pipermail/slurm-announce/2019/000018.html

Search for package or bug name: Reporting problems