CVE-2019-6443

NameCVE-2019-6443
DescriptionAn issue was discovered in NTPsec before 1.1.3. Because of a bug in ctl_getitem, there is a stack-based buffer over-read in read_sysvars in ntp_control.c in ntpd.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs919513

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ntpsec (PTS)buster1.1.3+dfsg1-2+deb10u1fixed
bullseye1.2.0+dfsg1-4fixed
bookworm, sid1.2.1+dfsg1-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ntpsecsource(unstable)1.1.3+dfsg1-1919513

Search for package or bug name: Reporting problems