CVE-2019-6778

NameCVE-2019-6778
DescriptionIn QEMU 3.0.0, tcp_emu in slirp/tcp_subr.c has a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1694-1
NVD severitymedium (attack range: local)
Debian Bugs921525

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u10fixed
stretch (security), stretch1:2.8+dfsg-6+deb9u5vulnerable
buster, sid1:3.1+dfsg-7fixed
slirp4netns (PTS)buster, sid0.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:3.1+dfsg-3medium921525
qemusourcejessie1:2.1+dfsg-12+deb8u10mediumDLA-1694-1
qemu-kvmsource(unstable)(unfixed)medium
slirp4netnssource(unstable)0.2.1-1medium

Notes

[stretch] - qemu <no-dsa> (Minor issue, pending for stable point update)
https://lists.gnu.org/archive/html/qemu-devel/2019-01/msg03132.html
https://git.qemu.org/?p=qemu.git;a=commit;h=a7104eda7dab99d0cdbd3595c211864cba415905

Search for package or bug name: Reporting problems