CVE-2019-6956

NameCVE-2019-6956
DescriptionAn issue was discovered in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. It is a buffer over-read in ps_mix_phase in libfaad/ps_dec.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1899-1
NVD severitymedium
Debian Bugs914641

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
faad2 (PTS)jessie2.7-8+deb8u1vulnerable
jessie (security)2.7-8+deb8u3fixed
stretch2.8.0~cvs20161113-1+deb9u1vulnerable
stretch (security)2.8.0~cvs20161113-1+deb9u2vulnerable
buster2.8.8-3vulnerable
bullseye, sid2.9.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
faad2source(unstable)2.8.8-3.1914641
faad2sourcejessie2.7-8+deb8u3DLA-1899-1

Notes

[buster] - faad2 <no-dsa> (Minor issue)
[stretch] - faad2 <no-dsa> (Minor issue)
https://sourceforge.net/p/faac/bugs/240/
https://github.com/knik0/faad2/issues/39
https://github.com/knik0/faad2/commit/6823e6610c9af1b0080cb22b9da03efb208d7d57

Search for package or bug name: Reporting problems