CVE-2019-6978

NameCVE-2019-6978
DescriptionThe GD Graphics Library (aka LibGD) 2.2.5 has a double free in the gdImage*Ptr() functions in gd_gif_out.c, gd_jpeg.c, and gd_wbmp.c. NOTE: PHP is unaffected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1651-1, DSA-4384-1
NVD severityhigh (attack range: remote)
Debian Bugs920728

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)jessie2.1.0-5+deb8u11vulnerable
jessie (security)2.1.0-5+deb8u12fixed
stretch (security), stretch2.2.4-2+deb9u4fixed
buster, sid2.2.5-5.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.5-5.1high920728
libgd2sourcejessie2.1.0-5+deb8u12highDLA-1651-1
libgd2sourcestretch2.2.4-2+deb9u4highDSA-4384-1

Notes

https://github.com/libgd/libgd/issues/492
https://github.com/libgd/libgd/commit/553702980ae89c83f2d6e254d62cf82e204956d0

Search for package or bug name: Reporting problems