CVE-2019-7164

NameCVE-2019-7164
DescriptionSQLAlchemy through 1.2.17 and 1.3.x through 1.3.0b2 allows SQL Injection via the order_by parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1718-1
NVD severityhigh
Debian Bugs922669

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlalchemy (PTS)jessie0.9.8+dfsg-0.1vulnerable
jessie (security)0.9.8+dfsg-0.1+deb8u1fixed
stretch1.0.15+ds1-1vulnerable
buster1.2.18+ds1-2fixed
bullseye, sid1.3.11+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlalchemysource(unstable)1.2.18+ds1-2922669
sqlalchemysourceexperimental1.3.0~b3+ds1-1
sqlalchemysourcejessie0.9.8+dfsg-0.1+deb8u1DLA-1718-1

Notes

https://github.com/sqlalchemy/sqlalchemy/issues/4481
https://github.com/sqlalchemy/sqlalchemy/commit/30307c4616ad67c01ddae2e1e8e34fabf6028414

Search for package or bug name: Reporting problems