CVE-2019-7659

NameCVE-2019-7659
DescriptionGenivia gSOAP 2.7.x and 2.8.x before 2.8.75 allows attackers to cause a denial of service (application abort) or possibly have unspecified other impact if a server application is built with the -DWITH_COOKIES flag. This affects the C/C++ libgsoapck/libgsoapck++ and libgsoapssl/libgsoapssl++ libraries, as these are built with that flag.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1681-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gsoap (PTS)jessie2.8.17-1+deb8u1vulnerable
jessie (security)2.8.17-1+deb8u2fixed
stretch2.8.35-4+deb9u2fixed
buster2.8.75-1fixed
bullseye2.8.75-2fixed
sid2.8.91-2fixed
r-other-x4r (PTS)bullseye, sid, buster1.0.1+git20150806.c6bd9bd-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gsoapsource(unstable)2.8.75-1
gsoapsourcejessie2.8.17-1+deb8u2DLA-1681-1
gsoapsourcestretch2.8.35-4+deb9u2
r-other-x4rsource(unstable)1.0.1+git20150806.c6bd9bd-2

Notes

https://www.genivia.com/advisory.html#Bug_in_gSOAP_versions_2.7.0_to_2.8.74_for_applications_built_with_the_WITH_COOKIES_flag_enabled_
https://lists.debian.org/debian-lts/2019/02/msg00131.html

Search for package or bug name: Reporting problems