CVE-2019-9021

NameCVE-2019-9021
DescriptionAn issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. A heap-based buffer over-read in PHAR reading functions in the PHAR extension may allow an attacker to read allocated or unallocated memory past the actual data when trying to parse the file name, a different vulnerability than CVE-2018-20783. This is related to phar_detect_phar_fname_ext in ext/phar/phar.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1679-1, DSA-4398-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)jessie5.6.33+dfsg-0+deb8u1vulnerable
jessie (security)5.6.40+dfsg-0+deb8u7fixed
php7.0 (PTS)stretch7.0.33-0+deb9u3fixed
stretch (security)7.0.33-0+deb9u6fixed
php7.3 (PTS)sid, buster, buster (security)7.3.11-1~deb10u1fixed
bullseye7.3.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)
php5sourcejessie5.6.40+dfsg-0+deb8u1DLA-1679-1
php7.0source(unstable)(unfixed)
php7.0sourcestretch7.0.33-0+deb9u2DSA-4398-1
php7.3source(unstable)7.3.1-1

Notes

Fixed in 5.6.40, 7.1.26, 7.2.14, 7.3.1
PHP Bug: https://bugs.php.net/bug.php?id=77247
https://github.com/php/php-src/commit/78bd3477745f1ada9578a79f61edb41886bec1cb (7.1)

Search for package or bug name: Reporting problems