CVE-2019-9213

NameCVE-2019-9213
DescriptionIn the Linux kernel before 4.20.14, expand_downwards in mm/mmap.c lacks a check for the mmap minimum address, which makes it easier for attackers to exploit kernel NULL pointer dereferences on non-SMAP platforms. This is related to a capability check for the wrong task.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1731-1, DLA-1771-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.74-1fixed
stretch4.9.189-3fixed
stretch (security)4.9.189-3+deb9u1fixed
buster4.19.67-2fixed
buster (security)4.19.67-2+deb10u1fixed
bullseye, sid5.2.17-1fixed
linux-4.9 (PTS)jessie (security)4.9.189-3+deb9u1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.19.28-1medium
linuxsourcejessie3.16.64-1mediumDLA-1731-1
linuxsourcestretch4.9.168-1medium
linux-4.9sourcejessie4.9.168-1~deb8u1mediumDLA-1771-1

Notes

Fixed by: https://git.kernel.org/linus/0a1d52994d440e21def1c2174932410b4f2a98a1 (5.0)
https://bugs.chromium.org/p/project-zero/issues/detail?id=1792

Search for package or bug name: Reporting problems