CVE-2019-9215

NameCVE-2019-9215
DescriptionIn Live555 before 2019.02.27, malformed headers lead to invalid memory access in the parseAuthorizationHeader function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1720-1, DSA-4408-1
NVD severityhigh (attack range: remote)
Debian Bugs924655

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
liblivemedia (PTS)jessie2014.01.13-1vulnerable
jessie (security)2014.01.13-1+deb8u3fixed
stretch2016.11.28-1+deb9u1vulnerable
stretch (security)2016.11.28-1+deb9u2fixed
buster, sid2018.11.26-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
liblivemediasource(unstable)(unfixed)high924655
liblivemediasourceexperimental2019.02.27-1high
liblivemediasourcejessie2014.01.13-1+deb8u3highDLA-1720-1
liblivemediasourcestretch2016.11.28-1+deb9u2highDSA-4408-1

Notes

Reporter advisory and analysis: https://tools.cisco.com/security/center/viewAlert.x?alertId=59708

Search for package or bug name: Reporting problems