CVE-2019-9325

NameCVE-2019-9325
DescriptionIn libvpx, there is a possible out of bounds read due to a missing bounds check. This could lead to remote information disclosure with no additional execution privileges needed. User interaction is needed for exploitation. Product: AndroidVersions: Android-10Android ID: A-112001302
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-4578-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvpx (PTS)buster1.7.0-3+deb10u1fixed
buster (security)1.7.0-3+deb10u3fixed
bullseye (security), bullseye1.9.0-1+deb11u2fixed
bookworm, bookworm (security)1.12.0-1+deb12u2fixed
sid, trixie1.14.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvpxsourcejessie(not affected)
libvpxsourcestretch1.6.1-3+deb9u2DSA-4578-1
libvpxsourcebuster1.7.0-3+deb10u1DSA-4578-1
libvpxsource(unstable)1.8.1-2

Notes

[jessie] - libvpx <not-affected> (Vunerable code introduced in 1.4.0)
https://github.com/webmproject/libvpx/commit/0681cff1ad36b3ef8ec242f59b5a6c4234ccfb88

Search for package or bug name: Reporting problems