CVE-2019-9628

NameCVE-2019-9628
DescriptionThe XMLTooling library all versions prior to V3.0.4, provided with the OpenSAML and Shibboleth Service Provider software, contains an XML parsing class. Invalid data in the XML declaration causes an exception of a type that was not handled properly in the parser class and propagates an unexpected exception type.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1710-1, DSA-4407-1
NVD severitymedium
Debian Bugs924346

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xmltooling (PTS)stretch (security), stretch1.6.0-4+deb9u2fixed
buster3.0.4-1+deb10u1fixed
bullseye, sid3.1.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xmltoolingsourcejessie1.5.3-2+deb8u4DLA-1710-1
xmltoolingsourcestretch1.6.0-4+deb9u2DSA-4407-1
xmltoolingsource(unstable)3.0.4-1924346

Notes

https://shibboleth.net/community/advisories/secadv_20190311.txt
https://issues.shibboleth.net/jira/browse/CPPXT-143
https://git.shibboleth.net/view/?p=cpp-xmltooling.git;a=commit;h=af27c422f551e16989ff6f1722d83614c8550eb5

Search for package or bug name: Reporting problems