CVE-2019-9639

NameCVE-2019-9639
DescriptionAn issue was discovered in the EXIF component in PHP before 7.1.27, 7.2.x before 7.2.16, and 7.3.x before 7.3.3. There is an uninitialized read in exif_process_IFD_in_MAKERNOTE because of mishandling the data_len variable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1741-1, DSA-4403-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)jessie5.6.33+dfsg-0+deb8u1vulnerable
jessie (security)5.6.40+dfsg-0+deb8u7fixed
php7.0 (PTS)stretch7.0.33-0+deb9u3fixed
stretch (security)7.0.33-0+deb9u6fixed
php7.3 (PTS)bullseye7.3.10-1fixed
buster, buster (security), sid7.3.11-1~deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)unimportant
php5sourcejessie5.6.40+dfsg-0+deb8u2DLA-1741-1
php7.0source(unstable)(unfixed)unimportant
php7.0sourcestretch7.0.33-0+deb9u3DSA-4403-1
php7.3source(unstable)7.3.3-1unimportant

Notes

Fixed in 7.1.27, 7.2.16, 7.3.3
PHP Bug: https://bugs.php.net/bug.php?id=77659

Search for package or bug name: Reporting problems