CVE-2019-9641

NameCVE-2019-9641
DescriptionAn issue was discovered in the EXIF component in PHP before 7.1.27, 7.2.x before 7.2.16, and 7.3.x before 7.3.3. There is an uninitialized read in exif_process_IFD_in_TIFF.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1741-1, DSA-4403-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch (security), stretch7.0.33-0+deb9u8fixed
php7.3 (PTS)buster, buster (security)7.3.19-1~deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5sourcejessie5.6.40+dfsg-0+deb8u2DLA-1741-1
php5source(unstable)(unfixed)
php7.0sourcestretch7.0.33-0+deb9u3DSA-4403-1
php7.0source(unstable)(unfixed)
php7.3source(unstable)7.3.3-1

Notes

Fixed in 7.1.27, 7.2.16, 7.3.3
PHP Bug: https://bugs.php.net/bug.php?id=77509

Search for package or bug name: Reporting problems