CVE-2019-9675

NameCVE-2019-9675
Description** DISPUTED ** An issue was discovered in PHP 7.x before 7.1.27 and 7.3.x before 7.3.3. phar_tar_writeheaders_int in ext/phar/tar.c has a buffer overflow via a long link value. NOTE: The vendor indicates that the link value is used only when an archive contains a symlink, which currently cannot happen: "This issue allows theoretical compromise of security, but a practical attack is usually impossible."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4403-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)jessie5.6.33+dfsg-0+deb8u1vulnerable
jessie (security)5.6.40+dfsg-0+deb8u4vulnerable
php7.0 (PTS)stretch (security), stretch7.0.33-0+deb9u3fixed
php7.3 (PTS)buster7.3.4-2fixed
sid7.3.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)unimportant
php7.0source(unstable)(unfixed)unimportant
php7.0sourcestretch7.0.33-0+deb9u3mediumDSA-4403-1
php7.3source(unstable)7.3.3-1unimportant

Notes

Fixed in 7.1.27, 7.3.3
PHP Bug: https://bugs.php.net/bug.php?id=77586

Search for package or bug name: Reporting problems