CVE-2019-9837

NameCVE-2019-9837
DescriptionDoorkeeper::OpenidConnect (aka the OpenID Connect extension for Doorkeeper) 1.4.x and 1.5.x before 1.5.4 has an open redirect via the redirect_uri field in an OAuth authorization request (that results in an error response) with the 'openid' scope and a prompt=none value. This allows phishing attacks against the authorization flow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs924747

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-doorkeeper-openid-connect (PTS)buster1.5.2-1vulnerable
sid1.5.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-doorkeeper-openid-connectsource(unstable)1.5.5-1medium924747

Notes

https://github.com/doorkeeper-gem/doorkeeper-openid_connect/issues/61
https://github.com/doorkeeper-gem/doorkeeper-openid_connect/pull/66

Search for package or bug name: Reporting problems