CVE-2019-9893

NameCVE-2019-9893
Descriptionlibseccomp before 2.4.0 did not correctly generate 64-bit syscall argument comparisons using the arithmetic operators (LT, GT, LE, GE), which might able to lead to bypassing seccomp filters and potential privilege escalations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs924646

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libseccomp (PTS)jessie2.1.1-1vulnerable
stretch2.3.1-2.1+deb9u1vulnerable
buster2.3.3-4vulnerable
bullseye2.4.1-2fixed
sid2.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libseccompsource(unstable)2.4.1-1unimportant924646

Notes

https://github.com/seccomp/libseccomp/issues/139
No security issue by itself

Search for package or bug name: Reporting problems