CVE-2020-10595

NameCVE-2020-10595
Descriptionpam-krb5 before 4.9 has a buffer overflow that might cause remote code execution in situations involving supplemental prompting by a Kerberos library. It may overflow a buffer provided by the underlying Kerberos library by a single '\0' byte if an attacker responds to a prompt with an answer of a carefully chosen length. The effect may range from heap corruption to stack corruption depending on the structure of the underlying Kerberos library, with unknown effects but possibly including code execution. This code path is not used for normal authentication, but only when the Kerberos library does supplemental prompting, such as with PKINIT or when using the non-standard no_prompt PAM configuration option.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2166-1, DSA-4648-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpam-krb5 (PTS)jessie4.6-3vulnerable
jessie (security)4.6-3+deb8u1fixed
stretch4.7-4vulnerable
stretch (security)4.7-4+deb9u1fixed
buster, buster (security)4.8-2+deb10u1fixed
bullseye, sid4.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpam-krb5source(unstable)4.9-1
libpam-krb5sourcebuster4.8-2+deb10u1DSA-4648-1
libpam-krb5sourcejessie4.6-3+deb8u1DLA-2166-1
libpam-krb5sourcestretch4.7-4+deb9u1DSA-4648-1

Notes

https://www.openwall.com/lists/oss-security/2020/03/31/1

Search for package or bug name: Reporting problems