CVE-2020-10674

NameCVE-2020-10674
DescriptionPerlSpeak through 2.01 allows attackers to execute arbitrary OS commands, as demonstrated by use of system and 2-argument open.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs954238

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libperlspeak-perl (PTS)jessie, stretch2.01-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libperlspeak-perlsource(unstable)(unfixed)954238
libperlspeak-perlsourcejessie(unfixed)end-of-life

Notes

[stretch] - libperlspeak-perl <ignored> (Will be removed in next point release)
[jessie] - libperlspeak-perl <end-of-life> (Not supported in jessie LTS)
https://rt.cpan.org/Public/Bug/Display.html?id=132173

Search for package or bug name: Reporting problems