CVE-2020-10722

NameCVE-2020-10722
DescriptionA vulnerability was found in DPDK versions 18.05 and above. A missing check for an integer overflow in vhost_user_set_log_base() could result in a smaller memory map than requested, possibly allowing memory corruption.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4688-1
NVD severitymedium
Debian Bugs960936

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dpdk (PTS)stretch16.11.11-1+deb9u1vulnerable
stretch (security)16.11.11-1+deb9u2fixed
buster18.11.6-1~deb10u1vulnerable
buster (security)18.11.6-1~deb10u2fixed
bullseye, sid19.11.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dpdksource(unstable)19.11.2-1960936
dpdksourcebuster18.11.6-1~deb10u2DSA-4688-1
dpdksourcestretch16.11.11-1+deb9u2DSA-4688-1

Search for package or bug name: Reporting problems