CVE-2020-10724

NameCVE-2020-10724
DescriptionA vulnerability was found in DPDK versions 18.11 and above. The vhost-crypto library code is missing validations for user-supplied values, potentially allowing an information leak through an out-of-bounds memory read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs960936

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dpdk (PTS)stretch (security), stretch16.11.11-1+deb9u2fixed
buster18.11.8-1~deb10u1fixed
buster (security)18.11.6-1~deb10u2fixed
bullseye, sid19.11.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dpdksourcestretch(not affected)
dpdksourcebuster18.11.6-1~deb10u2
dpdksource(unstable)19.11.2-1960936

Notes

[stretch] - dpdk <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems