CVE-2020-10755

NameCVE-2020-10755
DescriptionAn insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0 and all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0. When using openstack-cinder with the Dell EMC ScaleIO or VxFlex OS backend storage driver, credentials for the entire backend are exposed in the ``connection_info`` element in all Block Storage v3 Attachments API calls containing that element. This flaw enables an end-user to create a volume, make an API call to show the attachment detail information, and retrieve a username and password that may be used to connect to another user's volume. Additionally, these credentials are valid for the ScaleIO or VxFlex OS Management API, should an attacker discover the Management API endpoint. Source: OpenStack project
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cinder (PTS)stretch2:9.0.0-4vulnerable
buster2:13.0.3-1vulnerable
bullseye, sid2:16.1.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cindersourcejessie(unfixed)end-of-life
cindersource(unstable)2:16.1.0-1low

Notes

[buster] - cinder <no-dsa> (Minor issue)
[stretch] - cinder <no-dsa> (Minor issue)
[jessie] - cinder <end-of-life> (OpenStack component, not supported in jessie LTS)
https://bugs.launchpad.net/cinder/+bug/1823200
https://wiki.openstack.org/wiki/OSSN/OSSN-0086
check, affects as well python-os-brick or needs a respective update?

Search for package or bug name: Reporting problems