CVE-2020-10958

NameCVE-2020-10958
DescriptionIn Dovecot before 2.3.10.1, a crafted SMTP/LMTP message triggers an unauthenticated use-after-free bug in submission-login, submission, or lmtp, and can lead to a crash under circumstances involving many newlines after a command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4690-1
NVD severitymedium
Debian Bugs960963

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dovecot (PTS)jessie1:2.2.13-12~deb8u4fixed
jessie (security)1:2.2.13-12~deb8u7fixed
stretch (security), stretch1:2.2.27-3+deb9u5fixed
buster1:2.3.4.1-5+deb10u1vulnerable
buster (security)1:2.3.4.1-5+deb10u2fixed
sid1:2.3.7.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dovecotsource(unstable)(unfixed)960963
dovecotsourcebuster1:2.3.4.1-5+deb10u2DSA-4690-1
dovecotsourcejessie(not affected)
dovecotsourcestretch(not affected)

Notes

[stretch] - dovecot <not-affected> (Vulnerable code introduced in 2.3.0)
[jessie] - dovecot <not-affected> (Vulnerable code introduced in 2.3.0)
https://www.openwall.com/lists/oss-security/2020/05/18/1

Search for package or bug name: Reporting problems