CVE-2020-11020

NameCVE-2020-11020
DescriptionFaye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs959392

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-faye (PTS)buster, bullseye, sid1.2.4-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-fayesource(unstable)(unfixed)959392

Notes

[buster] - ruby-faye <no-dsa> (Minor issue)
https://github.com/faye/faye/security/advisories/GHSA-qpg4-4w7w-2mq5
https://github.com/faye/faye/commit/65d297d341b607f3cb0b5fa6021a625a991cc30e

Search for package or bug name: Reporting problems