CVE-2020-11082

NameCVE-2020-11082
DescriptionIn Kaminari before 1.2.1, there is a vulnerability that would allow an attacker to inject arbitrary code into pages with pagination links. This has been fixed in 1.2.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs961847

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-kaminari (PTS)stretch0.17.0-3vulnerable
buster1.0.1-4vulnerable
bullseye, sid1.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-kaminarisource(unstable)1.0.1-6961847

Notes

[jessie] - ruby-kaminari <no-dsa> (No reverse dependency)
https://github.com/kaminari/kaminari/security/advisories/GHSA-r5jw-62xg-j433
https://github.com/kaminari/kaminari/commit/8dd52a1aed3d2fa2835d836de23fc0d8c4ff5db8

Search for package or bug name: Reporting problems