CVE-2020-11935

NameCVE-2020-11935
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs964748

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
aufs (PTS)stretch4.9+20161219-1vulnerable
buster4.19+20190211-1vulnerable
sid5.2+20190909-1.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
aufssource(unstable)(unfixed)964748

Notes

[buster] - aufs <no-dsa> (Minor issue; CONFIG_IMA not enabled in kernel; can be fixed via point release)
[stretch] - aufs <ignored> (Minor issue; too many other aufs issues open)
To exploit the issue CONFIG_IMA in Kernel needs to be enabled.
linux/4.9.y had the config enabled, but was disabled in later versions
including linux/4.19.y.
https://sourceforge.net/p/aufs/mailman/message/37048642/
https://github.com/sfjro/aufs4-linux/commit/515a586eeef31e0717d5dea21e2c11a965340b3c
https://github.com/sfjro/aufs4-linux/commit/f10aea57d39d6cd311312e9e7746804f7059b5c8

Search for package or bug name: Reporting problems