CVE-2020-11984

NameCVE-2020-11984
DescriptionApache HTTP server 2.4.32 to 2.4.44 mod_proxy_uwsgi info disclosure and possible RCE
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2362-1, DSA-4757-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)stretch (security), stretch2.4.25-3+deb9u9fixed
buster, buster (security)2.4.38-3+deb10u4fixed
bullseye, sid2.4.46-1fixed
uwsgi (PTS)stretch2.0.14+20161117-3+deb9u2vulnerable
stretch (security)2.0.14+20161117-3+deb9u3fixed
buster2.0.18-1vulnerable
bullseye, sid2.0.19.1-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2sourcestretch(not affected)
apache2sourcebuster2.4.38-3+deb10u4DSA-4757-1
apache2source(unstable)2.4.46-1
uwsgisourcestretch2.0.14+20161117-3+deb9u3DLA-2362-1
uwsgisource(unstable)(unfixed)unimportant

Notes

[stretch] - apache2 <not-affected> (Vulnerable code not present)
https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2020-11984
https://www.openwall.com/lists/oss-security/2020/08/07/1
https://svn.apache.org/r1880251
https://github.com/apache/httpd/commit/0c543e3f5b3881d515d6235f152aacaaaf3aba72
uwsgi since 2.0.15-11 drops building the libapache2-mod-proxy-uwsgi{,-dbg}
packages which are provided by src:apache2 itself.

Search for package or bug name: Reporting problems