CVE-2020-12398

NameCVE-2020-12398
DescriptionIf Thunderbird is configured to use STARTTLS for an IMAP server, and the server sends a PREAUTH response, then Thunderbird will continue with an unencrypted connection, causing email data to be sent without protection. This vulnerability affects Thunderbird < 68.9.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2247-1, DSA-4702-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
thunderbird (PTS)stretch1:68.10.0-1~deb9u1fixed
stretch (security)1:68.12.0-1~deb9u2fixed
buster, buster (security)1:68.12.0-1~deb10u1fixed
bullseye1:68.12.0-1fixed
sid1:78.3.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
thunderbirdsourcejessie1:68.9.0-1~deb8u2DLA-2247-1
thunderbirdsourcestretch1:68.9.0-1~deb9u1DSA-4702-1
thunderbirdsourcebuster1:68.9.0-1~deb10u1DSA-4702-1
thunderbirdsource(unstable)1:68.9.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2020-22/#CVE-2020-12398

Search for package or bug name: Reporting problems