CVE-2020-12693

NameCVE-2020-12693
DescriptionSlurm 19.05.x before 19.05.7 and 20.02.x before 20.02.3, in the rare case where Message Aggregation is enabled, allows Authentication Bypass via an Alternate Path or Channel. A race condition allows a user to launch a process as an arbitrary user.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs961406

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slurm-llnl (PTS)jessie14.03.9-5+deb8u2fixed
jessie (security)14.03.9-5+deb8u5fixed
stretch16.05.9-1+deb9u4vulnerable
stretch (security)16.05.9-1+deb9u2vulnerable
buster, buster (security)18.08.5.2-1+deb10u1vulnerable
bullseye, sid19.05.5-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slurm-llnlsource(unstable)(unfixed)961406
slurm-llnlsourcejessie(not affected)

Notes

[buster] - slurm-llnl <no-dsa> (Minor issue)
[stretch] - slurm-llnl <no-dsa> (Minor issue)
[jessie] - slurm-llnl <not-affected> (Message Aggregation added in 14.11)
https://www.schedmd.com/news.php?id=236
https://lists.schedmd.com/pipermail/slurm-announce/2020/000036.html
Issue affects systems with Message Aggregation enabled

Search for package or bug name: Reporting problems