CVE-2020-14001

NameCVE-2020-14001
DescriptionThe kramdown gem before 2.3.0 for Ruby processes the template option inside Kramdown documents by default, which allows unintended read access (such as template="/etc/passwd") or unintended embedded Ruby code execution (such as a string that begins with template="string://<%= `). NOTE: kramdown is used in Jekyll, GitLab Pages, GitHub Pages, and Thredded Forum.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2316-1, DSA-4743-1
NVD severityhigh
Debian Bugs965305

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-kramdown (PTS)stretch1.12.0-1vulnerable
stretch (security)1.12.0-1+deb9u1fixed
buster1.17.0-1vulnerable
buster (security)1.17.0-1+deb10u1fixed
bullseye1.17.0-4vulnerable
sid2.3.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-kramdownsourceexperimental2.3.0-1
ruby-kramdownsourcestretch1.12.0-1+deb9u1DLA-2316-1
ruby-kramdownsourcebuster1.17.0-1+deb10u1DSA-4743-1
ruby-kramdownsource(unstable)2.3.0-3965305

Notes

https://github.com/advisories/GHSA-mqm2-cgpr-p4m6
https://github.com/gettalong/kramdown/commit/1b8fd33c3120bfc6e5164b449e2c2fc9c9306fde

Search for package or bug name: Reporting problems