CVE-2020-14314

NameCVE-2020-14314
DescriptionA memory out-of-bounds read flaw was found in the Linux kernel before 5.9-rc2 with the ext3/ext4 file system, in the way it accesses a directory with broken indexing. This flaw allows a local user to crash the system if the directory exists. The highest threat from this vulnerability is to system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2385-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1vulnerable
stretch (security)4.9.210-1+deb9u1vulnerable
buster4.19.146-1fixed
buster (security)4.19.152-1fixed
bullseye, sid5.9.1-1fixed
linux-4.19 (PTS)stretch (security)4.19.152-1~deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcebuster4.19.146-1
linuxsource(unstable)5.8.7-1
linux-4.19sourcestretch4.19.146-1~deb9u1DLA-2385-1

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1853922
https://git.kernel.org/linus/5872331b3d91820e14716632ebb56b1399b34fe1

Search for package or bug name: Reporting problems