CVE-2020-14346

NameCVE-2020-14346
DescriptionA flaw was found in xorg-x11-server before 1.20.9. An integer underflow in the X input extension protocol decoding in the X server may lead to arbitrary access of memory contents. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2359-1, DSA-4758-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xorg-server (PTS)stretch2:1.19.2-1+deb9u5vulnerable
stretch (security)2:1.19.2-1+deb9u6fixed
buster2:1.20.4-1vulnerable
buster (security)2:1.20.4-1+deb10u1fixed
bullseye2:1.20.8-2vulnerable
sid2:1.20.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xorg-serversourcestretch2:1.19.2-1+deb9u6DLA-2359-1
xorg-serversourcebuster2:1.20.4-1+deb10u1DSA-4758-1
xorg-serversource(unstable)2:1.20.9-1

Notes

https://lists.x.org/archives/xorg-announce/2020-August/003058.html
https://gitlab.freedesktop.org/xorg/xserver/-/commit/c940cc8b6c0a2983c1ec974f1b3f019795dd4cff

Search for package or bug name: Reporting problems