CVE-2020-14347

NameCVE-2020-14347
DescriptionA flaw was found in the way xserver memory was not properly initialized. This could leak parts of server memory to the X client. In cases where Xorg server runs with elevated privileges, this could result in possible ASLR bypass. Xorg-server before version 1.20.9 is vulnerable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2359-1, DSA-4758-1
NVD severitylow
Debian Bugs968986

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xorg-server (PTS)stretch2:1.19.2-1+deb9u5vulnerable
stretch (security)2:1.19.2-1+deb9u6fixed
buster, buster (security)2:1.20.4-1+deb10u1fixed
bullseye2:1.20.8-2vulnerable
sid2:1.20.9-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xorg-serversourcestretch2:1.19.2-1+deb9u6DLA-2359-1
xorg-serversourcebuster2:1.20.4-1+deb10u1DSA-4758-1
xorg-serversource(unstable)2:1.20.9-1968986

Notes

https://lists.x.org/archives/xorg-announce/2020-July/003051.html
https://gitlab.freedesktop.org/xorg/xserver/-/commit/aac28e162e5108510065ad4c323affd6deffd816

Search for package or bug name: Reporting problems